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Painter Brush Management – A Primer 

Or How to Keep Videos and other Extraneous Files Out of Your 
Brushes 

In this document, I hope to explain a bit about Painter Brushes and how they work in Painter.  I 
will talk about setting up brush libraries and how to install brushes.  I have previously provided 
a video, Brush Libraries and Installing Brushes, but it was based on the original release of 
Painter 12 and Painter 12 with the SP-1 Patch.  If you have upgraded to Painter 12.1, and you 
should, you will find that brush management has changed drastically and is vastly improved.  I 
know, strong words, and I truly believe they are the best descriptors for the new way to 
manage your brushes.  If you decide to stay with the earlier versions of Painter 12, I believe this 
document will help explain brushes for you, too. 

To get started, we need to understand where Painter saves its default brushes and where it 
saves any customization that you make to your brushes.  Painter uses two different places to 
store information about brushes. 

When you install Painter, it places its default brushes into an area that I call the Application 
Area or Path.  I am not sure if this is a standard term or not, but it works to help keep the two 
paths Painter uses separate in my mind.  After installation, if you make any changes to a brush, 
Painter places that information into the User Area or Path.  In both places the names of the files 
are the same, which is why it becomes confusing.  Let’s take a look at each. 
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Application Path 

Windows: 

 

MAC: 

 

 

User Path 
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Vista and Windows 7 

 

Windows XP 

 

Windows hides files.  If you cannot find AppData (Windows 7 or Vista) or Application Data 
(Windows XP) you will need to unhide the files.  To unhide files: 

1. Go to your start menu and open Control Panel. 
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2. At the top of the Control Panel click on the Tools Menu > Folder Options 
3. In the Folder Options Window, click on the View Tab 
4. Look down about half way and you will see Hidden Files and Folders 
5. Select Show Hidden Files, Folders and Drivers.  Select OK and you will be able to see 

your hidden drives. 

MAC 

 

I do not have a MAC, but a friend told me that the user files are hidden in the Lion OS like they 
are hidden in Windows.  To get to this path you need to: 

Go to you Finder Menu Bar and select Go > Go to Folder > in the dialog box that opens write 
~/Library; then click go and that will show hidden folders.  Now you can follow the first path 
described and select Application Support > Corel > Painter 12 > Default or Workspace name > 
Brushes > Painter 12 Brushes.  I am also told that if you right-click on the Corel Folder and select 
Make Alias from the drop down menu, you can then drag the Alias to your sidebar on the left 
under Favorites.  That will allow you to go directly to the Corel Folder without having to open 
your hidden files every time.  If these instructions do not work, it would be best to contact MAC 
Support. 

In all four User Paths, we end with a library called Painter 12 Brushes, which is the same name 
of the library in the Applications Path.  Both Painter 12 Brushes folders are Painter’s default 
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libraries.  Why do we need two libraries with the same name? How does each Library function?  
Could we make this any more confusing?  You betcha! 
What is a Brush Library and How Does It Work 
A brush library is simply a folder that contains brush categories and companion JPEGs.  
Interestingly, Painter 12 Brush library is placed in the Application Path when Painter is first 
installed and that is the last time Painter will write brush information to the Application Area. 
From this point on, Painter will only write to the libraries in the User Area.  That is correct, the 
Application Area is considered a protected area and the program will not write or save any 
brushes in the Application Area.  Instead it saves new information about variants to the User 
Area.  In other words, once you use a variant and change something as simple as the size of the 
brush, Painter holds that information in memory, and when you close Painter the information is 
stored in the User Area in the duplicate library and the duplicate brush category. 

Specifically, if you change the size of Acrylic > Bristle Brush, Painter holds this information in 
memory until you close Painter.  At that time it writes a file in Your User Path…Painter 12 
Brushes(Painter’s Default Library) > Acrylics (Brush Category Folder), that looks like this 
c_bristlebrush.xml.     

OK, drum roll please, here is what actually happens when you want to use the Acrylic > Bristle 
Brush.  The program first looks in the User Area for c_bristlebrush.xml.  If one is found, all the 
necessary information to construct the brush is located in the XML file including the changes 
you made to the brush when you last used it.  But if there isn’t a c_bristlebrush.xml, then 
Painter follows the Application Path and finds the default setting for the brush and constructs 
the brush variant accordingly.  To recap, Painter writes all change information to the User Path 
and looks there first for the necessary information to build the brush, but if it isn’t found, 
Painter looks to the Application area for the information. 

Painter writes and looks for the change information automatically; you don’t have to do 
anything to help.  But there is more information we need to process.  I have mentioned Brush 
Libraries and XML files, and I have talked about brush category folders among other things.  So 
what are Brush Categories, Brush Variants, and Companion JPEGs? 

What Are Brush Categories, Companion JPEGs, and Brush Variants 
At this point, we know that Brush Categories live inside of the Brush Library folder.  We find 
Brush Variants inside of Brush Categories.  In both the Applications Path and the User Path we 
have Brushes > Brush Library folder > Brush Category folder > Brush Variant files.  I like to think 
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of the Brush folder as a city.  Inside the city we have Libraries (Brush Libraries); inside the 
Library we have Stacks (Brush Category); inside a Stack are Books (Brush Variants). 

Along with Brush Categories, I have mentioned Companion JPEGs.  These can be found in the 
Brush Library, too: Brushes > Brush Library Folder > Companion.jpg file.  If you can remember 
the last time you were in a library (it has been years for me), you may remember that at the 
end of each stack is an identification plate that tells you what is located in the stack.  That is the 
job of the Companion JPEG.  Painter looks for the Companion JPEG and uses it for the Icon on 
the Brush Selector Bar to identify the Brush Category.  Without that JPEG, the Brush Category 
cannot be displayed. 

OK, we know what the Companion JPEG is for, but what about the Brush Category folder; what 
does it do?  The Brush Category Folder, or as I have called it, the stack, contains all the brush 
variant information, or in my metaphor, all the books.  For the moment, let’s limit the 
conversation to just the Default Brush Categories found under Painter 12 Brushes in the 
Application Area.  Remember, these are the ones written at the time of installation and never 
changed.  Each Brush Category has 3 or 4 files that concern a particular variant.   

The files are NIB, STK, JPEG, and XML files.  Specifically NIB files concern the nib shape of the 
brush variant; STK files are about the stroke; JPEG files create the dab; XML files contain all the 
information required to construct the brush.  XML files are by far the most important because 
the information in the other three files is contained in the XML file, too.  If I wanted to share a 
brush variant with you, all I need to give you is the XML file.  All you need to do is place the XML 
file into the Brush Category of your choice and voila, it will appear in that category the next 
time you open painter.  However, it will not show the stoke it creates in the Stroke Preview box 
or the nib type, etc.  Guess what, if you go to Brushes > Save Variant and save the variant as 
itself, then the NIB, STK, and JEPG files will be written from the XML file and the Stroke Preview, 
etc. will be populated.  It is important to note, that only Dab Types that are captured will have a 
JPEG file.  All other variants will have a NIB, STK, and XML file only. 

We have been talking about what is in the Default Brush Library and the Brush Category in the 
Application Path.  What about the same named files in the User Path?  There are differences.  
First, the Default Brush Library in the User Path contains Brush Categories but no JPEGs.  And 
second, the Brush Categories contain only c_brushname.xml files, the change files we 
mentioned earlier.  Remember this is the User Area and Painter writes the changes we make 
here.  There is no need to have the Companion JPEGs here because they are in the Default 
Library in the Application area.  Again, Painter first looks at the User Area to build the brush; if it 
needs more information, it looks at the Application Area.  So far, we discussed default Libraries, 
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Categories, and Variants.  Do custom Library, Category and Variants work the same as default 
ones?  Get ready; here it comes: Yes and No.  You didn’t think it would be a simple yes or no did 
you?   

Is There a Difference between Default and Custom Libraries, 
Categories, and Variants? 
Conceptually the default and custom libraries, categories, and variants are the same thing.  A 
library, custom or otherwise, is still a folder placed after Brushes in the path.  A Category Brush 
Folder with a Companion JPEG is still placed in the library folder and both are needed for 
Painter to recognize the Brush Category.  And Brush Variants regardless of type still have 3 or 4 
files with extensions of NIB, STK, JPG, and XML.  There are a few basic distinctions: 

1. The default library, categories, and variants are included and installed by Painter in 
the Application Area regardless of operating system. 

2. Custom libraries, categories, and variants created by the user are placed by Painter into 
the User Area. 

3. Libraries, categories and variants in the Application Area can be seen from any Painter 
Workspace, but those placed in the Custom Area can be seen only by a the specific 
workspace in the User Path.  Remember that part of the path that said Default or 
Workspace Name?  (Don’t worry about this now; we will get to it later.)  

Is that all there is to it?  Yes, that is about it, at least as far as Painter is concerned.  Painter 
installs default brush stuff into the Application Area, or if the user makes some brush stuff, 
Painter places it into the User Area.  However, if the user has administrative rights, which 
allows s/he access to the Application Area, then the user can also place brush stuff in the 
Application Area.  What?   

OK, let’s consider what we did before Painter 12.1.  We could make brush stuff like capture a 
category and save a variant using Painter.  But if we wanted to install a brush set made by 
someone else, we had to follow the Application Path or the User Path and place the Brush 
Category Folder and the Companion JPEG in the proper folder.  This seemingly simple task 
tripped many users and caused many headaches.  With Painter 12.1, everything got so much 
easier.  More about that later, let’s continue talking about all this brush stuff prior to 12.1. 

Painter’s choices are fixed; it installs default stuff to the Application area and custom stuff to 
the User area, but the user can pretty much do what s/he pleases including totally screwing up 
Painter by making unfortunate choices.  Over the past few years, I have looked at many folk’s 
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file structures and, trust me, been flabbergasted.  I have seen RIFF file paintings, PDFs, PSDs, 
and as the document title implies, videos, to name a few, inside of brush category folders or 
brush libraries in both the Application Area and User Area.  Oh stop snickering; I have seen this 
phenomenon with the most experienced users, too.  Accidents can happen and for the most 
part none of us need to be messing around in Painter’s guts in my opinion. 

Prior to 12.1, we didn’t have a choice; we had to mess around with Painter’s guts.  To install 
custom brushes from someone else, we had to place them in one of the paths described, but 
which one? 

Application Area or User Area, Which is Best 
Which is best indeed?  This argument has raged for years among those who care, and I am not 
one of those who care.  Well, maybe I care just a bit; I did write this epistle didn’t I? 

Both areas have their pros and cons.  But the most important element to consider is how 
Painter looks at both areas.  At this point I need to interject a new term, Workspace. 

Workspaces   
When you open Painter, the stuff that you see, document window, tool box, panels, custom 
palettes, etc., comprises the workspace.  When you open Painter the very first time, you open 
the factory default workspace.  As you add custom palettes or open certain panels or arrange 
the stuff on the workspace, Painter remembers the changes and opens the workspace as it 
appeared the last time you closed.  You are still working in the Default workspace, but it is a 
customized default workspace.  If you have to re-install painter, or use a Shift-Start, you will 
lose the changes to the customized default workspace and be returned to the factory default 
workspace.  Bummer! 

This “loss of your workspace heartache” can be avoided if you simply export (save) your 
workspace to your desktop, in your documents, or anywhere you like as long as it isn’t in the 
Application or User Areas.  To do this: 

1. Go to Window > Workspace > Export 
2. In the Export Window, navigate to where you want to save the workspace, name the 

workspace and select save.  The workspace is saved and renamed in Painter. 

If you need to install Painter again, or do a Shift-Start to the factory default, all your need to do 
to get your workspace back is to import your saved workspace.  All your custom stuff will return 
with the workspace.  One caveat, you only get back data from the saved date.  In other words, if 
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you exported your workspace once and several months later you need to import it…all the 
custom stuff made during those several months will be lost.  It is a very good idea to save your 
workspace frequently or at least every time you make any significant custom additions.  I know, 
I hear you…what does this have to do with brushes. 

And Which is best, Application or User Area 
Remember in the User Path, a section reads like this: Corel > Painter 12 > Default or the name 
of your workspace > Brushes.  In the User Path, the workspace comes before any of the custom 
stuff, which means that the custom stuff is workspace specific.  If I make a custom Brush 
Category in Workspace 1, it will not show up in Workspace 2…or any other workspace I have for 
that matter.   

However, if the custom brush category is placed in the Application Area, it will be available in all 
workspaces.  And probably of more interest, this custom brush information is not replaced 
when you reinstall Painter or do a Shift-Start.  It appears that the Application Area would be the 
best choice, but hold on; I do not think it is the best solution. 

I think you need to make a custom workspace and save it frequently.  After all, you do want to 
save your other custom stuff from reinstallation or Shift-Start.  Plus, custom brush stuff I make 
with Painter will be written to the User area anyway.  If I want to keep it in the Application area, 
I will need to move the new information from the user area to the application area daily or 
often.  It would be a nightmare to keep up with this stuff.   

It is simpler to follow Painter’s lead and leave the Application area as a read only area and use 
the User area for custom stuff.  Besides, with Painter 12.1 passing brushes around will be so 
much easier. 

Once again I hear you grumbling.  I know, I had that video showing how to load brushes into 
Painter 12 and I told you to load them into the Application Area.  The devil made me do it; 
honest.  Seriously, there was a bug in the first version of Painter 12 that wouldn’t allow you to 
place brush libraries in the User Area.  So we had to use the Application area until the 
Developers fixed the problem.  By the way, their solution is beautiful and elegant…more on that 
later. 

Quick Review of Material 
The following are the main points we have covered: 

1. Identified the Application Path/Area for the PC and MAC 
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2. Identified the User Path/Area for the PC and MAC 
3. Studied how to unhide files in the PC and the MAC (Lion OS) 
4. Learned what a Brush Library, Brush Category, and a Companion JPEG are and how they 

are used. 
5. Discovered the difference between Default Libraries, Brush Categories and Companion 

JPEGs and Custom Libraries, Brush Categories, and Companion JPEGs. 
6. Learned a bit about workspaces and how to export them 
7. Decided that installing brushes into the User Area was best.  OK…I decided that, but it is 

the right decision. 

How does Painter 12.1 Fit In 
Basically, you can still manually install brushes into painter 12.1 the same way you have always 
installed brushes in previous versions.  You still have a choice to manually install them in the 
Application area or the User area.  But with Painter 12.1, you also have the option to 
automatically install them, which is so easy and a vast improvement over the manual way. 

There is one caveat, if we are talking about older brushes, let’s say my Cool Spring set of 
brushes, then I or someone has to manually install them into painter.  Once done, I can export 
them as a brush category and provide anyone with that file.  The file will look like this Cool 
Spring.brushcategory.  Going forward, brush variants, brush categories and brush libraries 
created in Painter 12.1 will be exported as a single file.  In a very short while, all custom brush 
stuff will be handled this way without ever going into Painter’s file structure.  It is a grand new 
day. 

How to Export/Import a Brush Library 
Let’s say I have my Cool Spring brushes in a separate library named Skip’s Cool Spring.  There 
could be more than one brush category in the library, but for simplicity, let’s just have the Cool 
Spring Brush Category and the Companion JPEG inside of the library Skip’s Cool Spring. 

To export the library I would do this: 

1. Go to Brushes > Export > Brush Library 
2. In the Choose Brush Library window pop-up, I would choose Skip’s Cool Spring Library 

from the drop down list and click OK. 
3. A navigation window opens and at that point, I can actually change the name of the 

library to something else.  But let’s say I leave it as Skip’s Cool Spring and I navigate to 
some place on my computer to save the exported file.  I have a folder in my Documents 
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called Custom Painter Stuff.  In that folder I have many sub folders, for example, I have 
one called Exported Painter Libraries.  I would export Skip’s Cool Spring to that folder.  
The file will be called Skip’s Cool Spring.brushlibrary.  Most of the files are very small, 
but some are large. 

4. Next I want to send you the file.  I can do this anyway I wish.  If it is a particularly large 
file, I may want to zip it first. 

I have sent the file to you; what do you do: 

1. Save the file to a special place on your computer, like my Custom Painter Stuff folder.  
Just make sure it is an easy place that you can remember.  Not being able to find the file 
is a common occurrence. 

2. If the file was zipped; unzip it. 
3. Open Painter and go to Brushes > Import > Brush Library 
4. An import brush library navigation window will open.  Go to where you save Skip’s Cool 

Spring.brushlibrary file and select it and click OK. 
5. The library will be automatically installed into Painter 12.1 
6. And here is an easier alternative way.  Just save Skip’s Cool Spring.brushlibrary unzipped 

on your desktop.  With Painter open, simply double-click the file and it will automatically 
install in Painter 12.1.  Very easy and very cool and no need to go through Painter’s 
menu system. 

How to Export/Import a Brush Category 
What if I want to send you Cool Spring Brush Category and not a Cool Spring Brush Library?  It is 
just as easy as sending the Brush Library.  Here’s how: 

1. In Painter, make sure the Brush Library that holds the category that you want to export 
is active. 

2. Go to Brushes > Export > Category 
3. When the Export Category Navigation Window opens, navigate to where you want to 

export the file and click OK.  The file created will be Cool Spring.brushcategory, and like 
with a Brush Library, you can change the name of the category. 

4. Next I send you the created file…if too large, I zip it, but it shouldn’t be too large. 

And if you want to import the Brush Category, this is what you do. 

1. Save the file to a special place on your computer or drop it on your desktop. 
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2. Open Painter and make sure the library where you want to save the category is open or 
active. 

3. Go to Brushes > Import > Category and in the navigation window find the file you saved, 
select it, and say ok.  The Category will be automatically installed in the current Library. 

4. And as before, you can simply double-click the file and it will open in the current library 
without you going through Brushes > Import > Category. 

Can you believe this…it is so easy…thank you bunches Corel Painter Developers. 

How to Export/Import a Single Brush Variant 
Suppose I just created a new variant in Cool Spring Brush Category.  You already have the 
category, so I only need to send you the single variant.  Here is how I would do it: 

1. First I would make sure the brush I want to export is the current brush showing in the 
Brush Selector. 

2. Go to Brushes > Export > Brush and like brush library and category, I navigate to where I 
want to save the single variant and click OK.  The file name will be Name.brushvariant 
where Name is the name of the variant. 

3. I send you the created file 

This is what you do to import the single brush: 

1. Save the file to a special place or on your desktop 
2. Open Painter and make sure the library or the brush category you want to use is 

currently active. 
3. Go to Brushes > Import > Brush and navigate to the saved file, select it and say ok 
4. This time we get an interesting save window variant.  We have a save variant as box 

where we can name the variant anything we want.  And we have a Brush category drop 
down menu.  All brush categories in the selected library are available for us to select.  
Cool, but… 

5. Next to the drop down menu is a plus sign.  If we click the plus sign a new brush 
category window opens and we can create a new category for the variant.  Add a new 
name and click OK. 

6. The new name is now showing in the category drop down list.  Click ok and the new 
category will be created with the new brush variant inside.  Painter uses a default icon 
for the category, but you can change that later. 
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7. Alternately, you can double click the brush variant file and it will automatically be 
loaded into the currently active category.  You do not get a chance to create a new 
brush category. 

Talk about customization and ease of use.  I love Painter 12.1 

Wrap Up 
I don’t have any more to say.  Are you glad?  Well I am glad to be through with the umpteenth 
draft.  I hope this tome will be helpful to you.  I have to admit, I am hoping that I can reference 
this document whenever I have a brush loading question. 

Enjoy, 

Skip   
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